Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Guillaume

Pages: [1] 2 3 ... 24
1
Support / Re: Can't Initialize Yabause
« on: February 06, 2017, 05:37:15 AM »
You can have more details about what's wrong by opening View > Log.

I agree that it could be made a bit more clear :)

2
Support / Re: How do I install/compile Yabause 0.9.15 in Linux Mint 17.3?
« on: February 06, 2017, 05:34:38 AM »
It looks like you're running the cmake command from the wrong directory.

If you're following the doc, you should have created a new directory "build" at the same level than the "mini18", "yabause" and "yabauseut" directories.

The cmake command should be run from this newly created "build" directory.

3
Support / Re: please help (compiling instructions)
« on: December 19, 2016, 10:26:26 AM »
First, are you sure you want to build with msys? :) (and not Visual Studio?)

If you really want to build with msys, you should type that in cmd or power shell.

4
Suggestions / Re: specify games directory - Yabause on Android
« on: September 09, 2016, 06:00:56 AM »
I'm not sure to understand why it would be better... the exact files location doesn't matters much, no?

5
Support / Re: Problems when compiling with vs2015
« on: September 06, 2016, 07:50:43 AM »
Is there a plan to fix OpenGL support on Visual Studio builds ? This is in order to know if I should update the wiki about this or not.

Yeah... but just to make sure I understand: when building with OpenGL, Yabause works but crashes when closing application?
And that happens only when compiled with Visual Studio?

Completely unrelated question : do you confirm only SDL2 is required for Windows port ? If so, I should remove SDL from setup steps in the wiki.

Yep, you only need either SDL or SDL2, not both. We will remove support for SDL in the future.

6
Support / Re: Problems when compiling with vs2015
« on: September 05, 2016, 09:32:05 AM »
Yeah... that's a know bug.
For some reason, you need to clean your build directory before building a "full software" version after a "normal" version.
Now... I don't know how you "make clean" on Visual Studio :)

7
Support / Re: Problems when compiling with vs2015
« on: September 05, 2016, 08:05:22 AM »
Can you try compiling in "full software mode"? To do so, set YAB_WANT_OPENGL to OFF in CMake GUI.

8
Support / Re: Linux_ Yabause git compilation failure
« on: April 23, 2016, 07:16:16 AM »
It looks like a problem when compiling the dynamic recompiler, so a workaround would be to disable it:

Code: [Select]
cmake -DSH2_DYNAREC=OFF ../yabause
Now, can you give me more details about your build environnement? What Linux distribution are you using? Which compiler? It would help a lot if I can reproduce it :)

9
Support / Re: Linux_ Yabause git compilation failure
« on: April 22, 2016, 03:13:14 PM »
Can you try adding :

Code: [Select]
set_property(TARGET yabause PROPERTY POSITION_INDEPENDENT_CODE TRUE)
around line 678 in src/CMakeLists.txt (after the "add_library(yabause ..." line) and test if it fix it?

10
General / Re: Registering on the forums
« on: April 19, 2016, 02:58:28 PM »
Account approval isn't needed anymore.

You can register on the forums again :)

11
ehm... I'm not even sure what you don't understand here.

if you want something to work for your specific setup, you have two main options:

- find some developer with the same setup that's interested in fixing/adding the feature

- fix it yourself.

12
General / Re: Why does this forum ignore OSX controller support questions??
« on: February 29, 2016, 08:57:45 AM »
In fact, it's quite simple: we all have access to different kind of hardware and software. For example, I have an non-apple laptop (something people calls "PC", most of the time). I have Linux running on it. I can also boot to Windows, but that's something I'm almost never doing.

I also have a number of Android devices: phone(s), tablet and Nvidia Shield.

I have one non-working-anymore controller and I can plug my Shield controller in my laptop.

So, that's it. I can support/test/fix features for those hardware and software combinations. Sometimes those features will also works for other hardware and software. But sometimes not.
Same goes for other developers.

So, if you're lucky, there's a developer with the same setup than you. Otherwise, there's not much we can do about it.

(Btw, did you tried both the Cocoa and Qt ports?)

13
Support / Re: New Bilinear Filter on Linux
« on: August 27, 2015, 01:57:14 PM »
Well done, you just found what seems like a long-standing bug in the gtk port: every options after "autostart" options were ignored.
It's fixed now: https://github.com/Yabause/yabause/commit/0862bf4a57de627643d195ca167e7e77ad1b6f7e

14
Support / Re: New Bilinear Filter on Linux
« on: August 27, 2015, 12:13:34 PM »
Oh! Yes you are right. Works fine in software mode but doesn't do any filtering in opengl?

Yeah, (for now) only the software renderer supports it.

Also why doesnt the latest git want to run my game images from the command line? There is an image set in the virtual device in the options but when i run a different image from the command line it always loads the image set in the options menu

That's weird... it works for me with latest git.

What OS and port are you using?

15
Support / Re: New Bilinear Filter on Linux
« on: August 27, 2015, 04:32:43 AM »
Wait... when you're saying "svn", you mean "git", right? Because if you're trying to compile from our old svn repository... :)

Pages: [1] 2 3 ... 24