Recent Posts

Pages: 1 ... 8 9 [10]
91
 Some info in setting what is difference between STL and D Input would be also nice..
92
Suggestions / Game or iso name + Framterate in Window Titlebar
« Last post by RuThaN on September 07, 2016, 10:06:50 PM »
Hello,
pleas add statusbar with game or iso name and FPS counter or add this info in Window titlebar.
93
Support / Re: Anyway where we can use Xbox 360 controller to play the game???
« Last post by Denominator on September 06, 2016, 10:06:47 AM »
How did you get it to work?
94
Support / Re: Problems when compiling with vs2015
« Last post by cafe-alpha on September 06, 2016, 09:49:41 AM »
Yeah... but just to make sure I understand: when building with OpenGL, Yabause works but crashes when closing application?

Yes, that's correct.
I can reproduce the problem here, so don't hesitate to ask for testing if it can't be reproduced there.

And that happens only when compiled with Visual Studio?

Yes, because official build (made with MinGW) doesn't crashes.


Yep, you only need either SDL or SDL2, not both. We will remove support for SDL in the future.

Thank you for the confirmation :) I updated the wiki accordingly.
95
Support / Re: Problems when compiling with vs2015
« Last post by Guillaume on September 06, 2016, 07:50:43 AM »
Is there a plan to fix OpenGL support on Visual Studio builds ? This is in order to know if I should update the wiki about this or not.

Yeah... but just to make sure I understand: when building with OpenGL, Yabause works but crashes when closing application?
And that happens only when compiled with Visual Studio?

Completely unrelated question : do you confirm only SDL2 is required for Windows port ? If so, I should remove SDL from setup steps in the wiki.

Yep, you only need either SDL or SDL2, not both. We will remove support for SDL in the future.
96
Support / Re: Problems when compiling with vs2015
« Last post by cafe-alpha on September 06, 2016, 03:04:09 AM »
Yeah... that's a know bug.
For some reason, you need to clean your build directory before building a "full software" version after a "normal" version.
Now... I don't know how you "make clean" on Visual Studio :)

Sorry, I didn't had to download latest sources, or even rebuild everything yesterday ^^;
I tested today's sources in OpenGL-less mode, and couldn't reproduce the bug :] Thank you :-*

Is there a plan to fix OpenGL support on Visual Studio builds ? This is in order to know if I should update the wiki about this or not.


Completely unrelated question : do you confirm only SDL2 is required for Windows port ? If so, I should remove SDL from setup steps in the wiki.
97
Support / Re: Problems when compiling with vs2015
« Last post by Guillaume on September 05, 2016, 09:32:05 AM »
Yeah... that's a know bug.
For some reason, you need to clean your build directory before building a "full software" version after a "normal" version.
Now... I don't know how you "make clean" on Visual Studio :)
98
Support / Re: Problems when compiling with vs2015
« Last post by cafe-alpha on September 05, 2016, 09:07:37 AM »
Can you try compiling in "full software mode"? To do so, set YAB_WANT_OPENGL to OFF in CMake GUI.

Thank you for your help :)
I just tried, and get the compile error below :
Quote
4>D:\yabause_x64\build_20160215\src\qt\moc_YabauseGL.cpp(64): error C2027: use of undefined type 'QGLWidget'
4>  c:\qt\qt5.7.0\5.7\msvc2015_64\include\qtwidgets\qwidget.h(707): note: see declaration of 'QGLWidget'
4>D:\yabause_x64\build_20160215\src\qt\moc_YabauseGL.cpp(79): error C2027: use of undefined type 'QGLWidget'
4>  c:\qt\qt5.7.0\5.7\msvc2015_64\include\qtwidgets\qwidget.h(707): note: see declaration of 'QGLWidget'
4>D:\yabause_x64\build_20160215\src\qt\moc_YabauseGL.cpp(84): error C2027: use of undefined type 'QGLWidget'
4>  c:\qt\qt5.7.0\5.7\msvc2015_64\include\qtwidgets\qwidget.h(707): note: see declaration of 'QGLWidget'

I'll try with latest sources tomorrow.
99
Support / Re: Problems when compiling with vs2015
« Last post by Guillaume on September 05, 2016, 08:05:22 AM »
Can you try compiling in "full software mode"? To do so, set YAB_WANT_OPENGL to OFF in CMake GUI.
100
Support / Re: Problems when compiling with vs2015
« Last post by cafe-alpha on September 05, 2016, 05:37:50 AM »
Does it stop crashing if you comment out the body of VIDSoftDeInit in vidsoft.c? The OpenGL de-initialization code there might be the issue.

It unfortunately still crashes.


I tried latest sources built with VS2015 on 3 other machines, and couldn't get Yabause working :/
(Surprisingly, Yabaused crashes on startup on one test machine, while it still crashes on program close on my main laptop.)


I just updated yabause wiki about environment setup (here).
If a Yabause Windows developer could see what's wrong with latest sources and VS2015 compiling, that would be great :)
Pages: 1 ... 8 9 [10]