Author Topic: "Disc unsuitable for this system"  (Read 18719 times)

Nevin

  • Newbie
  • *
  • Posts: 3
    • View Profile
"Disc unsuitable for this system"
« on: December 04, 2007, 10:56:30 PM »
I've tried 3 different games and all give me this error, I tried using the iso file itself, then i tried burning it and running it from the cd.  Both give me the same error.   I even tried the Japanese and Euro bios' and that didn't work.

Is there something I'm doing wrong?

CyberWarriorX

  • Administrator
  • Sr. Member
  • *****
  • Posts: 375
    • View Profile
    • http://www.cyberwarriorx.com
"Disc unsuitable for this system"
« Reply #1 on: December 05, 2007, 09:26:59 PM »
What version of Yabause are you using? And what are your settings in Yabause set to?

Nevin

  • Newbie
  • *
  • Posts: 3
    • View Profile
"Disc unsuitable for this system"
« Reply #2 on: December 05, 2007, 10:21:31 PM »
I'm using the current version 0.9.1

As for the settings...right now I have Disc type set to Image and the Cue/Iso file set to the actual Iso file.  When I burned it to CD i changed the Disc type to CD and the path to my cd-rom drive. SH2 Core is set to Fast Interpreter.  Bios ROM file is set to the SEGA_100.bin file.  Backup RAM file created itself when I first ran it and is set to bkram.bin.  MPEG ROM file is empty, and cartridge file is set to none.  Video is set to OpenGL video interface.

CyberWarriorX

  • Administrator
  • Sr. Member
  • *****
  • Posts: 375
    • View Profile
    • http://www.cyberwarriorx.com
"Disc unsuitable for this system"
« Reply #3 on: December 07, 2007, 02:42:02 AM »
Double-check that the region is set to auto-detect. Also what games did you try?

Nevin

  • Newbie
  • *
  • Posts: 3
    • View Profile
"Disc unsuitable for this system"
« Reply #4 on: December 07, 2007, 02:57:27 AM »
Yes it was set to auto-detect, I also tried setting it to US but had the same problem.  Games I tried were: Albert Odyssey, Shining Wisdom, Shining Force III

dclark

  • Newbie
  • *
  • Posts: 1
    • View Profile
"Disc unsuitable for this system"
« Reply #5 on: October 21, 2008, 04:04:59 AM »
I'm having the same problem with Shining Force III.  I can get Panzer Dragoon Saga working, but not Shining Force.  

I'm using version 0.9.7.
Disc type: Image
SH2 Core:  Fast Interpreter
Region:  Auto-detect
BIOS: I've tried SEGA_100, SEGA_101, BIOS (EUR) (one for each region) and none of them seem to work
Backup RAM file:  bkram.bin
MPEG Rom File:  This is blank
Cartridge Type:  None

Please advise.

shadowmoon

  • Newbie
  • *
  • Posts: 1
    • View Profile
"Disc unsuitable for this system"
« Reply #6 on: November 14, 2008, 09:23:44 AM »
I am have the same probelm and then some. I would like to start off saying I do know what I am doing to a point. I have done stuff like this before and I even put the cfw on my psp. Here is my problem I have yabause 0.9.7 I have put the cue and bin on a cd, I made an iso and an iso image. I will either get Disc unsuitable for this system or it will load up to the cd player window type and show me either 1 or 2 tracks and I hit play and it will only give me audio. Am I missing something. I have the bios for this. The programs I used was magiciso and ultraiso. I have tried three games. Road Rash, Resident Evil and Shining Force III. I have tried to look on this fourm for step by step on what your files should look like and what the name should say. This is the most confusing emulator I have ever dealt with. It would be nice if a senior would do a step by step and this is what it should look like guide for this emulator as I can see alot of people are having a hard time getting this to run. For all I know it could be my bios. I have tried other saturn emulators and no luck with them. Thank you for your time in reading.

Selius

  • Newbie
  • *
  • Posts: 2
    • View Profile
"Disc unsuitable for this system"
« Reply #7 on: November 29, 2008, 06:53:27 PM »
same response as in another topic, but try this if it's not exactly what you were doing.

File>Settings>

Cue/Iso File
Browse
tick All Files as Files of type
pick the Shining Force 3.bin

dont use the .cue file

leave region to autodetect

ACLover

  • Newbie
  • *
  • Posts: 1
    • View Profile
"Disc unsuitable for this system"
« Reply #8 on: February 12, 2009, 02:30:24 AM »
I downloaded Virtual On Cyber Trooper and been trying to play it, but the game reads the disk as "Disk unusable by the system." I converted the .mdf to a .iso and a .bin with Magic ISO. Its on auto detect. It still reads it as a unreadable disk.

h1gh3agle

  • Newbie
  • *
  • Posts: 1
    • View Profile
"Disc unsuitable for this system"
« Reply #9 on: March 18, 2009, 03:14:34 AM »

tesla

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: "Disc unsuitable for this system"
« Reply #10 on: October 23, 2014, 06:01:43 AM »
I downloaded a different BIN/ISO, and the game I was having this problem with worked (Shining Force III). Also, use ISO-FIle Virtual Drive under the CD Rom option in settings.