Author Topic: How do I install/compile Yabause 0.9.15 in Linux Mint 17.3?  (Read 759 times)

jperk

  • Newbie
  • *
  • Posts: 6
    • View Profile
How do I install/compile Yabause 0.9.15 in Linux Mint 17.3?
« on: February 05, 2017, 06:27:12 AM »
I'm trying to install QT version since QT version of 9.13.1-1 runs best on my PC. I'm using the following DOC http://wiki.yabause.org/index.php5?title=Readme_QT and everything in terminal goes well until I get to the Run cmake: cmake -DYAB_PORTS=qt ../yabause command. From there it just says directory doesn't exist and I haven't a clue what to do to prevent this error. If anyone could please help I would greatly appreciate it!

Guillaume

  • Administrator
  • Sr. Member
  • *****
  • Posts: 359
    • View Profile
    • ./confiture && cake
Re: How do I install/compile Yabause 0.9.15 in Linux Mint 17.3?
« Reply #1 on: February 06, 2017, 05:34:38 AM »
It looks like you're running the cmake command from the wrong directory.

If you're following the doc, you should have created a new directory "build" at the same level than the "mini18", "yabause" and "yabauseut" directories.

The cmake command should be run from this newly created "build" directory.

jperk

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: How do I install/compile Yabause 0.9.15 in Linux Mint 17.3?
« Reply #2 on: February 06, 2017, 03:18:08 PM »
Can you please provide a step by step guide? I'm sort of new to Linux. I'm trying to play Astal because it does not work with my current Yabause verison. Thanks!

And yes the new directory "yabause" with build folder, etc was created in my home/ user / directory. After I enter: cmake -DYAB_PORTS=qt ../yabause I get the following:

jperk@john-GA-78LMT ~/yabause/build $ cmake -DYAB_PORTS=qt ../yabause
-- The CXX compiler identification is unknown
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE)
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Could NOT find GLUT (missing:  GLUT_glut_LIBRARY GLUT_INCLUDE_DIR)
-- Could NOT find GLEW (missing:  GLEW_INCLUDE_DIR GLEW_LIBRARY)
-- CMAKE_SYSTEM_NAME Linux
-- CMAKE_SYSTEM_PROCESSOR x86_64
-- The compiler CMAKE_CXX_COMPILER-NOTFOUND doesn't have enough C++11 support. Dynarecs disabled.
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Qt5 Found
-- Configuring incomplete, errors occurred!
See also "/home/jperk/yabause/build/CMakeFiles/CMakeOutput.log".
See also "/home/jperk/yabause/build/CMakeFiles/CMakeError.log".


EDIT


For those having similar problems I managed to find a solution to my above errors. Before attempting to download Yabause installation (linux) from wiki doc make sure you do the following commands:

sudo apt-get update && sudo apt-get install build-essential

and then

apt-get install g++

Now proceed with Yabause instructions.
« Last Edit: February 07, 2017, 01:36:08 AM by jperk »

Janilow

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Событие
How do I install/compile Yabause 0 9 15 in Linux Mint 17 3
« Reply #3 on: February 27, 2017, 06:50:23 PM »
I received a license, but cannot find where in the admin interface to install it.  Running eCAT 4.0.4 on Linux.

Help?

Tony