Author Topic: Dragon Force Can't Recruit  (Read 597 times)


  • Newbie
  • *
  • Posts: 1
    • View Profile
Dragon Force Can't Recruit
« on: February 07, 2018, 10:02:11 AM »

 So i had this working fine on my old machine with an older version of Yabause. That machine died so i downloaded and set it up on this machine.  I have the original CD which i made my own image of, so i'm using an undamaged, original owned copy, AKA i have the legal right to run it. I also found a copy of the Rom online. I get the same result with both images.

The game plays and runs fine, everything seems to be working. However, when we get to the map screen, i use the 'Ok' button and it works as normal, but when i go into the actual on map castle menu to recruit soldiers or deploy generals, it does not pop up the "Recruit/Release" Window. Meaning I can't resupply troops, I can't deploy generals to attack and I can't move out of my own castles at all. All i can do is stand still and watch the other monarchs play.

Emulator/Saturn/yabause-0.9.15/Bios/Sega Saturn BIOS v1.00 (US).bin
Enabled built-in HLE
Enable Frame skip limiter
Multithread (4)
OpenGL and Software both tried
Software OSD interface
DirtectX Sound
Enable HIgh quality Sound
Region: Autodetect
SH2 Interpt
SH2 Interp